跳到主内容
版本:6.x

pnpm prune

移除不需要的软件包

配置项

--prod

删除在 devDependencies 中指定的包。

--no-optional

删除在 optionalDependencies 中指定的包。

警告

prune 命令目前不支持在 monorepo中递归执行。 可以删除一个只安装 production 依赖的monorepo 的几个 node_modules 文件夹,然后重新再用 pnpm install --prod 安装。