跳到主内容
Version: 5.x

pnpm outdated

检查过期的 packages。 此命令可以通过提供参数来限制为已安装 packages的一个子集(支持 patterns)。

示例:

pnpm outdated
pnpm outdated "*gulp-*" @babel/core

配置项

--recursive, -r

在发现的子目录所有package 中,或者如果在一个工作空间执行时,在工作空间的所有package中检查过期依赖。

--filter <package_selector>

阅读更多有关 filter 的内容。

--global

列出过期的全局package

--long

添加于:v4.0.0

打印详细信息。

--no-table

添加于:v4.0.0

以列表格式打印过期的依赖项,而不是默认的表格格式。 适合小的控制台。

--compatible

添加于:v4.7.0

仅打印满足 package.json 规范的版本。

--dev, -D

添加于:v4.7.0

仅检查 devDependencies

--prod, -P

添加于:v4.7.0

仅检查dependenciesoptionalDependencies

--no-optional

添加于:v4.7.0

不去检查 optionalDependencies