Ana içeriğe atla
Version: 5.x

pnpm outdated

Checks for outdated packages. The check can be limited to a subset of the installed packages by providing arguments (patterns are supported).

Şu şekilde:

pnpm outdated
pnpm outdated "*gulp-*" @babel/core

Parametreler

--recursive, -r

Check for outdated dependencies in every package found in subdirectories, or in every workspace package when executed inside a workspace.

--filter <paket_seçici>

Buradan daha fazla bilgiye ulaşabilirsin.

--global

List outdated global packages.

--long

Sürüm 4.0.0 ve sonrasında geçerli

Print details.

--no-table

Sürüm 4.0.0 ve sonrasında geçerli

Prints the outdated dependencies in a list format instead of the default table. Good for small consoles.

--compatible

Sürüm 4.7.0 ve sonrasında geçerli

Prints only versions that satisfy specifications in package.json.

--dev, -D

Sürüm 4.7.0 ve sonrasında geçerli

Checks only devDependencies.

--prod, -P

Sürüm 4.7.0 ve sonrasında geçerli

Checks only dependencies and optionalDependencies.

--no-optional

Sürüm 4.7.0 ve sonrasında geçerli

Doesn't check optionalDependencies.