Перейти к основному содержимому
Version: 5.x

pnpm outdated

Проверяет наличие устаревших пакетов. Проверка может быть ограничена подмножеством установленных пакетов путем указания аргументов (поддерживаются шаблоны).

Примеры:

pnpm outdated
pnpm outdated "*gulp-*" @babel/core

Опции

--recursive, -r

Проверяет наличие устаревших зависимостей в каждом пакете, находящемся в подкаталогах, или в каждом пакета рабочего пространства (воркспейса) при выполнении внутри рабочего пространства (воркспейса).

--filter <селектор пакета>

Подробнее о фильтрации.

--global

Список устаревших глобальных пакетов.

--long

Добавлено в: v4.0.0

Показывает подробности.

--no-table

Добавлено в: v4.0.0

Выводит устаревшие зависимости в формате списка вместо таблицы по умолчанию. Хорошо подходит для небольших консолей.

--compatible

Добавлено в: v4.7.0

Показывает только версии, удовлетворяющие указанными диапазонам в package.json.

--dev, -D

Добавлено в: v4.7.0

Проверяет только devDependencies.

--prod, -P

Добавлено в: v4.7.0

Проверяет только dependencies и optionalDependencies.

--no-optional

Добавлено в: v4.7.0

Не проверяет optionalDependencies.