본문으로 건너뛰기
버전: 7.x

pnpm만 허용

프로젝트에서 pnpm을 사용하는 경우, 다른 사람들이 실수로 npm install이나 yarn을 실행하는 것을 원하지 않습니다. 개발자들이 다른 패키지 매니저를 사용하는 것을 막기 위해선 다음 preinstall 스크립트를 package.json에 추가합니다:

{
"scripts": {
"preinstall": "npx only-allow pnpm"
}
}

이제 누군가가 npm install이나 yarn을 실행한다고 해도, 오류가 발생하고 설치가 진행되지 않을 것입니다.

Npm v7을 사용한다면, npx -y를 사용하세요.