본문으로 건너뛰기
버전: 6.x

pnpm outdated

오래된 패키지를 확인합니다. 검사는 인수를 제공하여 설치된 패키지의 하위 집합으로 제한될 수 있습니다 (패턴이 지원됨).

예시:

pnpm outdated
pnpm outdated "*gulp-*" @babel/core

옵션

--recursive, -r

하위 디렉토리에 있는 모든 패키지에서 오래된 의존성을 확인하거나 워크스페이스 내에서 모든 워크스페이스 패키지에서 오래된 의존성을 확인하십시오.

--filter <package_selector>

필터링에 대해 자세히 알아보세요.

--global, -g

오래된 글로벌 패키지를 나열합니다.

--long

Added in: v4.0.0

세부 정보를 출력합니다.

--no-table

Added in: v4.0.0

기본 테이블 대신 목록 형식으로 오래된 의존성을 출력합니다. 작은 콘솔에 좋습니다.

--compatible

버전 4.7.0에서 추가됨

package.json의 명세를 충족하는 버전만 출력합니다.

--dev, -D

버전 4.7.0에서 추가됨

devDependencies만 확인합니다.

--prod, -P

버전 4.7.0에서 추가됨

dependenciesoptionalDependencies만 확인합니다.

--no-optional

버전 4.7.0에서 추가됨

optionalDependencies은 확인하지 않습니다.