본문으로 건너뛰기
버전: 6.x

pnpm audit

버전 4.3.0에서 추가됨

설치된 패키지의 알려진 보안 문제를 확인합니다.

보안 문제가 발견되면 pnpm update를 통해 의존성을 업데이트하십시오. 간단한 업데이트로 모든 문제가 해결되지 않으면 override를 사용하여 취약하지 않은 버전을 강제합니다. 예를 들어 lodash@<2.1.0 가 취약한 경우 이 override를 사용하여 lodash@^2.1.0를 강제 실행합니다.

package.json
{
"pnpm": {
"overrides": {
"lodash@<2.1.0": "^2.1.0"
}
}
}

또는 pnpm audit --fix을 실행합니다.

옵션

--audit-level <심각도>

  • 유형: low, moderate, high, critical
  • 기본값: 낮음

Only print advisories with severity greater than or equal to <severity>.

--fix

버전 6.11.0에서 추가됨

취약하지 않은 버전의 의존성을 강제하기 위해 package.json 파일에 override를 추가하세요.

--json

Output audit report in JSON format.

--dev, -D

Only audit dev dependencies.

--prod, -P

Only audit production dependencies.

--no-optional

Don't audit optionalDependencies.

--ignore-registry-errors

버전 6.7.1에서 추가됨

레지스트리가 200이 아닌 상태 코드로 응답하면 프로세스가 0으로 종료되어야 합니다. 따라서 레지스트리가 실제로 발견된 취약점에 성공적으로 응답하는 경우에만 프로세스가 실패합니다.