Passa al contenuto principale
Versione: 7.x

Consenti solo pnpm

Quando usi pnpm in un progetto, non vuoi che gli altri eseguano accidentalmente npm install o yarn. Per evitare che gli sviluppatori usino altri gestori di pacchetti, puoi aggiungere il seguente script preinstall nel tuo package.json:

{
"scripts": {
"preinstall": "npx only-allow pnpm"
}
}

Ora, ogni volta che qualcuno esegue npm install o yarn, otterrà un messaggio di errore e l'installazione non procederà.

Se usi npm v7, usa npx -y.