Passa al contenuto principale
Versione: 6.x

pnpm outdated

Verifica la presenza di pacchetti obsoleti. Il controllo può essere limitato a un sottoinsieme dei pacchetti installati fornendo argomenti (i modelli sono supportati).

Esempi:

pnpm outdated
pnpm outdated "*gulp-*" @babel/core

Opzioni

--recursive, -r

Controlla le dipendenze obsolete in ogni pacchetto trovato nelle sottocartelle o in ogni pacchetto all'interno dello spazio di lavoro, se eseguito in uno spazio di lavoro.

--filter <selettore_pacchetto>

Ulteriori informazioni sui filtri.

--global, -g

Elenca i pacchetti globali obsoleti.

--long

Aggiunto nella versione: v4.0.0

Stampa i dettagli.

--no-table

Aggiunto nella versione: v4.0.0

Stampa le dipendenze obsolete in un formato elenco anziché nella tabella predefinita. Ottimo per console piccole.

--compatible

Aggiunto nella versione: v4.7.0

Stampa solo le versioni che soddisfano le specifiche in package.json.

--dev, -D

Aggiunto nella versione: v4.7.0

Controlla solo le dipendenze di sviluppo (devDependencies).

--prod, -P

Aggiunto nella versione: v4.7.0

Controlla solo le dipendenze (dependencies) e le dipendenze opzionali (optionalDependencies).

--no-optional

Aggiunto nella versione: v4.7.0

Non controlla le dipendenze opzionali (optionalDependencies).