Passa al contenuto principale
Versione: 6.x

pnpm audit

Aggiunto nella versione: v4.3.0

Verifica la presenza di problemi di sicurezza noti con i pacchetti installati.

Se vengono rilevati problemi di sicurezza, prova ad aggiornare le tue dipendenze tramite pnpm update. Se un semplice aggiornamento non risolve tutti i problemi, usa le sostituzioni per forzare versioni che non sono vulnerabili. Ad esempio, se lodash@<2.1.0 è vulnerabile, usa questo override per forzare lodash@^2.1.0:

package.json
{
"pnpm": {
"overrides": {
"lodash@<2.1.0": "^2.1.0"
}
}
}

In alternativa, esegui pnpm audit --fix.

Opzioni

--audit-livello <gravità>

  • Tipo: low, moderate, high, critical
  • Predefinito: low

Stampa solo avvisi con gravità maggiore o uguale a <gravità>.

--fix

Aggiunto nella versione: v6.11.0

Aggiungi sostituzioni al package.json per forzare versioni non vulnerabili delle dipendenze.

--json

Rapporto di audit in uscita in formato JSON.

--dev, -D

Controlla solo le dipendenze di sviluppo.

--prod, -P

Controlla solo le dipendenze di produzione.

--no-optional

Non controllare le dipendenze opzionali (optionalDependencies).

--ignore-registry-errors

Aggiunto nella versione: v6.7.1

Se il registro risponde con un codice di stato diverso da 200, il processo dovrebbe terminare con 0. Quindi il processo fallirà solo se il registro risponde effettivamente con successo con le vulnerabilità trovate.