Passa al contenuto principale
Version: 5.x

pnpm audit

Aggiunto nella versione: v4.3.0

Verifica la presenza di problemi di sicurezza noti con i pacchetti installati.

Opzioni

--audit-livello <gravità>

  • Tipo: low, moderate, high, critical
  • Predefinito: low

Stampa solo avvisi con gravità maggiore o uguale a <gravità>.

--json

Rapporto di audit in uscita in formato JSON.

--dev, -D

Controlla solo le dipendenze di sviluppo.

--prod, -P

Controlla solo le dipendenze di produzione.

--no-optional

Non controllare le dipendenze opzionali (optionalDependencies).