Langsung ke konten utama
Versi: 6.x

pnpm audit

Ditambahkan di: v4.3.0

Cek untuk masalah keamanan yang diketahui dengan paket-paket yang telah terpasang.

Jika masalah keamanan ditemukan, coba perbarui dependensi Anda melalui pnpm update. Jika sebuah update sederhana tidak memperbaiki semua masalah, gunakan overrides untuk memaksa versi yang tidak rentan. Misalnya, jika lodash @<2.1.0 rentan, gunakan overrides untuk memaksa lodash@^2.1.0:

package.json
{
"pnpm": {
"overrides": {
"lodash@<2.1.0": "^2.1.0"
}
}
}

Atau sebagai alternatif, jalankan pnpm audit --fix.

Options

--audit-level <severity>

  • Type: low, moderate, high, critical
  • Default: low

Tampilkan saran dengan tingkat keparahan yang lebih besar dari atau sama dengan <severity>.

--fix

Ditambahkan di: v6.11.0

Tambahkan penggantian ke file package.json untuk memaksa versi dependensi yang tidak rentan.

--json

Keluarkan laporan audit dalam format JSON.

--dev, -D

Hanya audit dependensi dev.

--prod, -P

Only audit production dependencies.

--no-optional

Jangan audit optionalDependencies.

--ignore-registry-errors

Ditambahkan dalam: v6.7.1

Jika registri merespons dengan kode status non-200, proses harus keluar dengan 0. Jadi prosesnya akan gagal hanya jika registri benar-benar berhasil merespons dengan kerentanan yang ditemukan.